NETRC(5) BSD File Formats Manual NETRC(5)
netrc - user configuration for ftp
This file contains configuration and autologin information for the File
Transfer Protocol client ftp(1).
The .netrc file contains login and initialization information used by the
auto-login process. It resides in the users home directory. The fol
lowing tokens are recognized; they may be separated by spaces, tabs, or
Identify a remote machine name. The auto-login process
searches the .netrc file for a machine token that matches the
remote machine specified on the ftp command line or as an open
command argument. Once a match is made, the subsequent .netrc
tokens are processed, stopping when the end of file is reached
or another machine or a default token is encountered.
default This is the same as machine name except that default matches
any name. There can be only one default token, and it must be
after all machine tokens. This is normally used as:
default login anonymous password user@site
thereby giving the user automatic anonymous ftp login to
machines not specified in .netrc. This can be overridden by
using the -n flag to disable auto-login.
Identify a user on the remote machine. If this token is
present, the auto-login process will initiate a login using the
Supply a password. If this token is present, the auto-login
process will supply the specified string if the remote server
requires a password as part of the login process. Note that if
this token is present in the .netrc file for any user other
than anonymous, ftp will abort the auto-login process if the
.netrc is readable by anyone besides the user.
Supply an additional account password. If this token is
present, the auto-login process will supply the specified
string if the remote server requires an additional account
password, or the auto-login process will initiate an ACCT com
mand if it does not.
Define a macro. This token functions like the ftp macdef com
mand functions. A macro is defined with the specified name;
its contents begin with the next .netrc line and continue until
a null line (consecutive new-line characters) is encountered.
If a macro named init is defined, it is automatically executed
as the last step in the auto-login process.
Linux NetKit (0.17) September 23, 1997 Linux NetKit (0.17)